What Is Frame Relay?

Frame relay is layer 2 protocol, which is used to connect LANs i.e. Local Area Networks and transfer data across WAN i.e. Wide Area Network. It shares data over the WAN using X.25 technology.

How it works?

Frame Relay uses the special purpose hardware components including frame routers, bridges & switches which are used to forward traffic from multiple connections over a shared physical link. Each connection uses a ten-bit (10 bit) DLCI i.e. Direct Link Connection Identifier for unique channel addresses.

Practical Implementation of Frame Relay

Consider three Routers- R1, R2 & R3 as shown in the figure below.

Frame- Relay Implementation on 3 Routers

The above diagram shows the different routers with their implemented settings.

In the three routers have following configurations:

  1. R1 router has following configurations: –

Interface   se 0/0/0.1 (To make frame relay connection with R2)

IP               172.168.1.1/24

DLCI           100

 

Interface   se 0/0/0.2 (To make frame relay connection with R3)

IP               172.168.3.1/24

DLCI           300

 

  1. R2 router has following configurations: –

Interface   se 0/0/0.1 (To make frame relay connection with R1)

IP               172.168.1.2/24

DLCI           101

Interface   se 0/0/0.2 (To make frame relay connection with R3)

IP               172.168.2.1/24

DLCI           200

 

  1. R3 router has following configurations: –

Interface   se 0/0/0.1 (To make frame relay connection with R1)

IP               172.168.1.2/24

DLCI           201

Interface   se 0/0/0.2 (To make frame relay connection with R3)

IP               172.168.2.1/24

DLCI           301

 

How to configure frame relay?

 

Given below are the commands to configure frame relay on R1

R1(config-if)#interface Serial0/0/0

R1(config-if)#no shut

R1(config-if)#encapsulation frame-relay

R1(config-if)#exit

R1(config)#

R1(config-subif)#interface Serial0/0/0.1 point-to-point

R1(config-subif)#ip address 172.168.1.1 255.255.255.0

R1(config-subif)#frame-relay interface-dlci 100

R1(config-subif)#exit

R1(config)#

R1(config)#interface Serial0/0/0.2 point-to-point

R1(config-subif)#ip address 172.168.3.1 255.255.255.0

R1(config-subif)#frame-relay interface-dlci 300

Given below are the commands to configure frame relay on R2

R2(config-if)#interface Serial0/0/0

R2(config-if)#no shut

R2(config-if)#encapsulation frame-relay

R2(config-if)#exit

R2(config)#

R2(config-subif)#interface Serial0/0/0.1 point-to-point

R2(config-subif)#ip address 172.168.1.2 255.255.255.0

R2(config-subif)#frame-relay interface-dlci 101

R2(config-subif)#exit

R2(config)#

R2(config)#interface Serial0/0/0.2 point-to-point

R2(config-subif)#ip address 172.168.2.1 255.255.255.0

R2(config-subif)#frame-relay interface-dlci 200

Given below are the commands to configure frame relay on R3

R3(config)#interface Serial0/0/0

R3(config-if)#no shut

R3(config-if)#encapsulation frame-relay

R3(config-subif)#interface Serial0/0/0.1 point-to-point

R3(config-subif)#ip address 172.168.2.2 255.255.255.0

R3(config-subif)#frame-relay interface-dlci 201

R3(config-subif)#exit

R3(config)#interface Serial0/0/0.2 point-to-point

R3(config-subif)#ip address 172.168.3.2 255.255.255.0

R3(config-subif)#frame-relay interface-dlci 301

R3(config-subif)#exit

 

Result:

Router R1 is connected to R2 and R3, where frame relay DLCI configured on R1 is 100 for R2 and is configured with 300 for R3 which is used to connect them over a network without any routing protocol.

Frame relay result from router R1

Router R2 is connected to R1 and R3, where frame relay DLCI configured on R2 is 101 for R2 and is configured with 200 for R3 which is used to connect them over a network without any routing protocol.

 

Frame relay result from router R2

Router R3 is connected to R1 and R2, where frame relay DLCI configured on R3 is 201 for R2 and is configured with 301 for R1 which is used to connect them over a network without any routing protocol.

Conclusion:

From the above results it can be seen that router R1, R2 & R3 are able to connect to each other over Wide Area Network(WAN) using the Frame Relay protocol.

For more practical’s like this join Codec Networks for CCNA certification and training in Delhi.

 

About

Codec Networks provides IT Trainings from EC Council CEH ECSA, LPT, CHFI, Network Security, Penetration Testing, ISACA, ISC2, PECB ISO 27001LA LI, Cisco Networking CCNA CCNP, Linux Administration RHCE, Prog Languages JAVA, Advanced Java, android development. We also offer B2B Industry Solutions and Services in IT | Information|Cyber Security in Delhi NCR India.

View all posts by